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What’s New

Spheron image support
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Cyclone can now natively import HDR panoramic imagery captured by Spheron cameras.

Batch import and alignment of NCTech iSTAR and SpheronVR panoramic imagery

A new importer has been added that supports single image or batch import of ISTAR and
Spheron panoramic images. Additionally, the importer provides automatic scan-to-image
alignment for these external panoramic images.

Workflow for importing Spheron and iSTAR panoramic images into Cyclone:

1.

2.

Import your scan data (Leica scan data, €57, as well as most other vendor formats are
supported). In addition, you must have either Spheron or iISTAR images that match the scan

Either register your data in Cyclone, or import data that has already been registered.

3. After importing, select the ScanWorld icon or project folder (for multiple ScanWorlds) in the

Open

Open Temporary ModelSpace View

Create and Open ModelSpace View

Open TruSpace
Update Original ModelSpace

Import...

Import Panoramic Images...
Batch Import...

Import Leica System 1200...
mport Geometric Objects...
Import ScanStation Data
Import MultiStation MS50 Data
Import as Auto Align Project
Import Pegasus Project...
Export...

Store in JetStream ProjectVault...

Exit

Cyclone Navigator window hierarchy, then right-click or from the File menu select Import
Panoramic images....

4. Navigate to the folder that contains the panoramic files and click OK.

@) Browse For Folder

Select the (root) folder containing the panoramic images.

2k

Autodesk_Revit_ MEP_2016_English_Win_64b
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Thruster
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Cancel
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5. The Match Images to Scans dialog will appear and begin to load the scan and image pairs.

@) Match Images to Scans — a X

Unlocked Locked

Images

Scans

Lock All Locked 0 of 2 OK Cancel

The scans are matched with the images by time stamp. The times do not need to match;
Cyclone will look for the earliest time from both data sources and begin calculating
matches.

6. If all the displayed pairs are matched, use the dialog’s ALL button to move all the pairs into the Locked
tab. Only pairs in the locked tab will be processed into Cyclone

@ Match Images to Scans

Unlocked  Locked

7. If the images need to be manually matched, the user can move the “film strip” of images or scans until
a correct pair are displayed together. Here are a list of tools used to match the pairs manually:

a. The active pair (or pair that will be moved to the Locked tab when the Lock button is clicked) is
highlighted in Cyan\Blue.

b. Right-click and drag moves the image or scan’s azimuth in the window left or right to help
matching. (The orientation/azimuth of the scan and image do not need to be aligned in the
preview window. This tool is only to help the user visually identify which images and scans are
pairs.)

c. Left-click and drag moves the whole “film strip” row under the mouse cursor.

d. Ctrl+Tab changes the rendering of the scan under the mouse cursor and will cycle through
intensity hue, grayscale, and RGB.

e. Left double click moves the row to the left or right. Left double click only works when clicked on
a non-active pair.

f. Right double click sends the active pair to the lock tab.

8. Continue through the list and match all the image/scan pairs and send them to the Locked tab.
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9. Once all pairs are in the Locked tab click OK to begin processing.

@) Match Images to Scans = [m] X

Aligning

—001: 'Sean—1

Unlock All Processing 1 of 2 [Spheron AG] OK Cancel

10. When finished you will be prompted to confirm the import and proceed:

]

=% Found? matching scenes for the 2 selected ScanWoarlds,
{ 1.e. (<scanworld>: <scan>: <imagefscene>)

SWH-001: Scan-1: ChiUsers\CUGYDesktopiRailroadS4W0142016-03-31_13-31-57_SN121368 sph
SW-002: Scan-1: Ci\Users\CUG\DesktopiRailroadS4W02,2016-03-31_14-08-51_SMN121368 sph

Proceed to import?

Ok Cancel

11. The import into Cyclone will proceed and new Multi-images will be created.

Import Panoramic Images

Importing panoramic images...

| Cancel |

The new Multi-images will be added to the ScanWorlds, but will not replace existing
Multi-images. The scan will be colored with the RGB from the new, imported Multi-
image.

12. Once imported, check the new image/scan combination by selecting the ScanWorld and right clicking
and selecting Open TruSpace.

-2 DotProduct
2 P40

h ScanWorld [Registration 2]
&1 P40
@1 DotProdr
A% ScanWo Open TruSpace
=i Spheron an 5
© 1 Project 1 Batch Apply Multiimages
o EIE Batch Blend Multilmages
Ao sW-0 Tone Map Pano Image..

4 DotProdi
31 Project2 Create
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HDR Tone Map Editor

When importing internal-camera HDR imagery from a P-Series ScanStation, Cyclone applies a
default HDR Tone Map if the HDR option was used during image collection. External panoramic
image systems, such as the Spheron, will also apply an HDR tone map to its images. Cyclone
users now have an option to edit the HDR Tone Map of any HDR panoramic image through a
new user interface. Users can select from different HDR algorithms, individual parameters for
each algorithm, and apply the final settings to a ScanWorld’s HDR panorama. Each ScanWorld’'s
HDR imagery is editable individually for ultimate customization.

Workflow:

1. Select the ScanWorld containing the HDR imagery and click on Tone Map Pano Image...

=28 SERVERS
£ @ AOAKNOBCUGO2 (unshared)
i Office-DotProduct
i@ Spheron and iStar
@ FLAveBthAlley-20150429

i@ Oregon Bridge

i Plant_5
i Pegasus
o @ HOR
=3 P4ORE Open TruSpace
= Stal
J.I Batch Apply Multilmages
@ SHORTCUTS Batch Blend Multilmages
(1 SCANNERS Tone Map Pano Image...
Create >
Shortcut in Windows >

Undo

Clear Undo/Redo
Copy

Delete

Rename

2. The Tone Map Editor will open. There are six tabs that represent the different tone map algorithms
available. By selecting the tabs you can view the different results.

@) Tone Map Editor — O X

Cyclone Reinhard Drago Mantiuk Durand Linear

l s Contrast v

Default Pick Gray | Preview : ScanWorld_0_53.hds Cancel
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3. In addition to the algorithm tabs, there are settings in a pull down menu on the right for each tone map
option. Pick a selection from the pull-down and then move the slider left and right to see the change in
the live preview of the image.

Cyclone Reinhard Drago Mantiuk Durand Linear

Default Pick Gray | Preview : ScanWerld_0_53.hds Cancel

4. There is also a Pick Gray button. Select this button and double click a representative gray pixel on the
image. The image will adjust its tonal range levels based on the pick.

Cyclone Reinhard Drage Mantiuk Durand Linear

Default Pick GFa Preview : ScanWorld_0_53.hds Cancel

5. When satisfied with the changes, click the OK button and the HDR image will be processed into a
Multi-image for the ScanWorld.

Import Leica Pegasus System Project Data

Cyclone can now directly import project data from Leica Geosystems’ Pegasus series mobile and
backpack systems.

Import DotProduct Data

Cyclone can now directly import .dp format data from DotProduct software and handheld
scanners.

Publish TruView Positions from Cyclone Camera Marker Positions

TruView positions are no longer restricted to scanner setups. Users can publish TruViews from
camera object markers inserted into the ModelSpace. When publishing a ModelSpace to
TruView, if camera markers exist in the ModelSpace, the user will be prompted to choose to
publish TruViews from the camera positions. Currently, this is an either/or option. It is not possible
to publish TruViews from both the scanner locations and the camera positions simultaneously.

This feature is not limited to static terrestrial scanner data. Users can now create TruViews from
any location, in any data set, including mobile and backpack data, handheld data, aerial LIDAR

data, or point clouds from UAVSs.

Cyclone PUBLISHER license will now enable the insert Camera and insert Camera (Height)
functionality. As in the past, Cyclone MODEL and SURVEY also turn on these features.
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Workflow for publishing TruViews from camera marker positions:

1. From the ModelSpace View go to Create Object > Insert > Camera, this will insert a camera
position at the screen perspective. You can also insert multiple camera positions using multi-
pick, and then go to Create Object > Insert > Camera (Height)...

[ Create Object | EditObject Tools UserApps Help

Segment Cloud 3

Segment Polyline

Slice 3

¥ | UseParts Table

Fit to Cloud s
Fit Fenced s

Fit to Cloud Options v

Extrude Shape (by 2 picks) y

Fit Edge..

Find Pipes Automatically.

Filter Pipes..

Region Grow 3

Insert , Vertex.

Insert Copy of Object's Points Line Segment...

Extract Cloud from Selection Patch...

Merge Box

Eorars Steel Section s
Copye Cone..

From Pick Points 3 Ciwdlzr

From Intersections v SEDEES

From Curves , Teorus..

Elbow...

Reducing Elbow...
Welding Neck Flange...
Blind Flange...
Concentric Reducer..
Eccentric Reducer..

Valve...

Tee..

Camera
Camera (Height)...

2. Once the camera positions (from either method) are placed, orient to the view from which
you want the TruView SiteMap to be generated.

NOTE: Camera positions have to be within the view to be published, and publishing from a
KeyPlan will not honor the camera positions.

N -
%y ModelSpace: Pegasus-P40 : ModelSpace View 1 ‘
File | Edit Selection View Viewpoint Create Objec

Import...

Export...

Export Pick Points...

Export PCF...

Publish Site Map...

Store in JetStream ProjectVault...

3. Go to File > Publish Site Map...

4. Browse for a folder to save the site map and TruView Files in.

5. If there are cameras in the view, Publisher will recognize them and ask if you want to publish
TruViews from the camera marker positions:
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By TruView Publisher =

'e' Do you want to publizh Truviews from camera marker positions.

6. Continue with the Site Map and TruView Settings dialogs as normal.

Cyclone now publishes image data to JetStream ProjectVault

Cyclone will now include panoramic image data when publishing datasets to JetStream
ProjectVault. This enables JetStream to utilize background panoramic images with JetStream
Viewer and CloudWorx TruSpace viewers. Users must also have JetStream 1.2 or later for
JetStream ProjectVault to read the image data from Cyclone 9.1.4 or later.

Additional FARO File Support at Import
Cyclone has been updated with the latest FARO SDK 5.5.3.

New CLM 1.5

CloudWorx now includes and supports Leica Client License Manager (CLM) 1.5, which offers
greater stability.

Bug Fixes

e Fixed a bug where transformation parameters were not written back correctly to .zfs files

e Fixed a bug where iISTAR cube maps of 2496x2496 pixels were imported as only 1248x1248
pixels

o Fixed a bug where the external camera Pose Editor in Cyclone was taking an abnormally long
time to process P-series ScanStation data

e Fixed a bug where drawing a Circle Fence with a large diameter would cause Cyclone to crash

e Fixed a bug where the automatic Find Black & White Targets tool at import would create
duplicate target vertices over targets manually acquired in the field on the scanner

Leica Cyclone 9.1.4 Compatibility and Upgrades

Windows 10 Support

Cyclone now supports the Windows 10 operating system.

Working with Older 32-bit Windows Operating Systems

If using older computer systems with Microsoft Windows 32 bit OS (XP or Windows 7), there may
be stability and memory issues while using certain functions. We recommend the following
settings to offset these issues:

1. Turn off Advanced Rendering from the Initialization tab in Preferences
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2. Set the Load and Display setting for pcE data to three million under the Point Cloud tab in
Preferences

Cyclone Database Management Recommendation

To avoid possible database inconsistencies or corruption while moving or copying databases, we
recommend the following:
= Locate each .imp file in its own folder
= When copying, moving or backing up databases, copy/move/back up the complete database
folder, including the .imp file, eventlog folder and files, and recovery folder and files
= The eventlog records administrative events and critical errors
= The recovery file keeps databases consistent, avoiding data corruption that may happen in
rare situations
=  When adding databases to Cyclone, a warning dialog is displayed if a database’s recovery
folder cannot be found when it is added to the database server. Push the More Info button
for more information.

Upgrading to Cyclone 9.1.4 from Cyclone 6.0.x - 9.1.3

You must have Administrator-level privileges on your workstation to correctly install Leica Cyclone
software.

Run the Cyclone 9.1.4 InstallShield and follow the directions in the InstallShield Wizard to
proceed with the installation. Please heed the warning message about compatibility of earlier
version databases.

Compatibility with Cyclone 9.1.4 AND Cyclone 8.1.3 or Earlier Versions

Cyclone 9.1.4 databases are NOT backward compatible with previous Cyclone versions 8.1.3 and
earlier. Databases that are updated using this version of Cyclone cannot then be used with earlier
versions. If you need to work with your data in older versions of Cyclone, you should make an
archive copy of your database(s) prior to upgrading. Since it can take some time to update and
optimize Cyclone databases, we recommend that you optimize your databases overnight,
particularly when multiple databases are involved.
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